Group Connect personalization strings failing validation in Content Builder preview
Trailblazer Community

Group Connect personalization strings failing validation in Content Builder preview

Marketing Cloud Mobile

Last updated 2021-10-11 ·Reference W-9933022 ·Reported By 1 users

In Review

Summary
When attempting to perform a Subscriber Preview of a LINE message that contains GroupConnect personalization strings in the message content within Content Builder, validation errors are returned consistently. When the text body/message content does not contain personalization strings, the content preview is displayed without errors.

Repro
1. Navigate to Content Builder
2. Create a new LINE message
3. Add Text Content to new message
4. Include personalization string content in Text body (I.E. %%[ SET @JOBID = LINE_JOB_ID ]%%)
5. Perform subscriber preview
6. Encounter validation errors

Workaround
Using AMPScript, you can specify the context of your personalization strings and the context by which the AMPScript fires. You can use the following code to omit portions of the AMPScript in the preview:

%%[
IF _messagecontext == 'SEND' THEN
]%%
%%SET @JOBID = LINE_JOB_ID%%
%%[ ELSE ]%%
<p>
Example message content
</p>
%%[ ENDIF ]%%

This workaround will not address the issue of the send-time attributes causing a validation error - but does allow you to preview the other components of the message without encountering the validation errors.

Reported By (1)

Any unreleased services, features, statuses, or dates referenced in this or other public statements are not currently available and may not be delivered on time or at all. Customers who purchase our services should make their purchase decisions based upon features that are currently available.