Marketing Cloud Connect Settings page will fail to load when a Salesforce Org has a large number of Objects
Trailblazer Community

Marketing Cloud Connect Settings page will fail to load when a Salesforce Org has a large number of Objects

Marketing Cloud Integrations , Marketing Cloud Admin

Last updated 2020-06-09 ·Reference W-6769124 ·Reported By 40 users

No Fix

Summary
Having a large number of Custom Objects in a Salesforce Org will cause the Marketing Cloud Connect Settings page to error/fail to load after entering the Marketing Cloud API User credentials.

Repro
- Install Marketing Cloud Connect package
- Configure the Marketing Cloud for Marketing Cloud Connect
- Configure the CRM for Marketing Cloud Connect
- On the Marketing Cloud tab, enter in the Marketing Cloud API user credentials and click Connect
- Notice the Settings will fail to load with one of the following errors:

"No Send Classifications were found in Marketing Cloud. Please contact your system administrator."

OR

"Sorry, something went wrong.
We ran into an internal error. Try again or open a support case in the Help and Training portal"

Workaround
- Create a custom tab for the Configuration records
- After initial API user integration, open the configuration record and add all fields to layout using the edit layout button.
- Manually edit the record to reflect the settings you will need.
- Required Fields: Send Types, Support Ticket Recipient, Days Tracked (value should be between 0 and 366), Frequency, Target Audience

Any unreleased services, features, statuses, or dates referenced in this or other public statements are not currently available and may not be delivered on time or at all. Customers who purchase our services should make their purchase decisions based upon features that are currently available.