Auto-Greeting intermittently not displaying when utilizing Chat in Lightning Console
Trailblazer Community

Auto-Greeting intermittently not displaying when utilizing Chat in Lightning Console

Service Cloud Console , Lightning , Omni-Channel

Last updated 2020-12-02 ·Reference W-7553162 ·Reported By 59 users

Fixed - Spring '21

Summary
Lightning Console chats my sometimes not display the auto greeting set up via configuration. This is due to a race condition where the auto-greeting is sending before the chat log has loaded, therefore it will not render correctly.

Repro
1. Log in and navigate to the Lightning Console where you use Omni-Channel.

2. Make sure that you have an auto-greeting that is to be displayed when a new chat comes in.

3. Submit a series of chats.

4. As an agent, rapidly accept these chats up to your capacity. You will need more than 1 set for the agent capacity.

5. Notice that intermittently, the auto-greeting will not show for some of the chats.

*Please Note: This can affect chats that are waiting in an agent's Omni Widget that are transferred to another agent in the event of the previous agent going offline. This will affect chats that are waiting to be accepted by an agent.

Workaround
None at this time. The chats will still work correctly, except for the fact that some will be missing the Auto-Greeting.

Any unreleased services, features, statuses, or dates referenced in this or other public statements are not currently available and may not be delivered on time or at all. Customers who purchase our services should make their purchase decisions based upon features that are currently available.