When I save an Apex class in the Dev Console, code coverage stops working - Ideas - Salesforce Trailblazer Community
Trailblazer Community

All Ideas

Idea Details

Post an Idea
80  Points
Open
Idea has been posted. Give it an upvote or downvote.

When I save an Apex class in the Dev Console, code coverage stops working

Development (Apex, LWC & VF)

I needed to reset code coverage after I refactored a class in the Winter '14 edition.  The Help says to edit and save the class in the Dev Console.  (This is not very helpful since I'm working wtih the Eclipse IDE, and this will cause conflicts.)  However, I try it.  Sure enough, my code coverage vanishes for that class.

Then I run the tests again...but the code coverage stays vanished.  I've run the tests a dozen times...I can see the percentage covered, but the red and blue shaded lines are gone.  They won't come back.

How am I supposed to develop when I can't check code execution anymore on a critical class?  This product is not ready for prime time, and it's going to add days to my development cycle.  Need a fix!

Merge Idea · Flag

  • Upvotes
  • Downvotes

Ideas

Apps

from AppExchange

Questions

No results found.

Help us to keep IdeaExchange clean by pointing out overlapping ideas. We'll investigate your suggestion and merge the ideas if it makes sense.



 

 

Thanks for your merge suggestion. We will review it shortly and merge the ideas if applicable.

Salesforce takes abuse situations very seriously. Examples of abuse include but are not limited to posting of offensive language or fraudulent statements. To help us process your request as quickly as possible, please fill out the form below describing the situation. For privacy and security reasons, the final outcome of an abuse case may not be revealed to the person who reported it.


 

Thank you for your feedback. We take abuse seriously and will investigate this issue and take appropriate action.